The Sith Legacy
Hello and welcome to the forum of The Sith Legacy. Please sign up/or login to use this forum. Hope you have a nice day!


Keeping JK2 alive through unity, fun, and friendship
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
We've moved to tsl.jk2.info, in order to be closer to the rest of the community - Go register!

Share | 
 

 Must haves

View previous topic View next topic Go down 
AuthorMessage
GLoCK

avatar

Posts : 14
Join date : 2015-07-16
Age : 18
Location : Hungary

PostSubject: Must haves   Wed Jan 13, 2016 9:29 pm

I thought i make a list of strongly recommended mods and pk3s so here they are.

JK2MV: JK2MV(stands for Jedi Knight 2 Multi version) allows you to play all versions of the game without having to install each version seperately, includes a minimizer and seperate GameData directory). You need to have version 1.04 of JK2 for this to work. Supports Windows, Linux, MacOSX, and has a serverside which enables HTTP downloads. Download: [url=jk2mv.org]jk2mv.org[/url]

KaMod clientside 1.02 and 1.04: Kamod clientside is developed by Kameleon.

  1.04: http://tsljk2.friendhood.net/t42-clientside-beta-kamod-1-04-edition

  1.02: http://rosjk2.freeforums.org/kamod-clientside-open-alpha-t210.html

Hilt Pack: https://dl.dropboxusercontent.com/u/7899346/jkhub/jko/weapons/sabers/modcompatiblehilts.zip
Back to top Go down
 
Must haves
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Must haves
» U22 Guild Ship and Amenity Changes
» Haves and Wants inside
» wants and haves list
» Queen's amiibo list: haves & wants

Permissions in this forum:You cannot reply to topics in this forum
The Sith Legacy :: Downloads :: Must haves-
Jump to: